/ Home Assistant

Probleme avec HA et CFFI

pip

J'ai rencontré un problème sur mon installation Home Assistant aujourd'hui, cet article peut vous aider...

Exception

Lors du dernier redemarrage de HA, j'ai obtenu ce genre d'erreur :

Exception: Version mismatch: this is the 'cffi' package version 1.11.4, located in '/home/gano/.homeassistant/deps/lib/python3.5/site-packages/cffi/api.py'.  When we import the top-level '_cffi_backend' extension module, we get version 1.10.0, located in '/usr/local/lib/python3.5/dist-packages/_cffi_backend.cpython-35m-x86_64-linux-gnu.so'.  The two versions should be equal; check your installation.

Du coup pas mal de devices ne fonctionnaient plus, comme la multiprise Broadlink, les calendriers google, et certains services online.

Pour résoudre le problème voila comment proceder :

On désinstalle le package python :

sudo pip uninstall cffi

Puis on reinstalle le packet dans la version necessaire ici 1.11.4 :

sudo pip install cffi==1.11.4

Plus qu'à redemarrer Home Assistant.

Probleme avec HA et CFFI
Share this